PHP7時代の Zencart v1.5.6a 日本語版をリリース!

17. 02. 13

弊社(有限会社ビッグマウス)は、海外のオープンソース型ECサイトシステムとしては、最も実績を持ったプログラムの一つである、Zen Cart の最新版 v1.5.6a の日本語対応版をリリースいたしました!

"Zen cart v1.5.6a" は、現在(2019年4月現在)最新の Zencart です。

このバージョンからデフォルトのテンプレートと共に、管理画面にもレスポンシブデザインが標準になり、よりモバイルフレンドリーな環境になっています。
何より重要なことが、PHP7 に対して完全対応しており、PCI DSSセキュリティ基準にも準拠したきわめて高性能かつ、安全なシステムになっていることです。

弊社が2008年にリリースした Zen Cart v1.3.8aは、年間2000ダウンロードを超える人気プログラムとなり、その後 Zen Cart v1.3.9hへとマイナーバージョンアップなどの対応を行っておりましたが、PHP7の時代になり対応が緊急となったこともあり、今回は10年ぶりに最新版ベースでリニューアルしたリリースとなりました。

プログラムの特徴は、PHP7に完全対応したシステムと、レスポンシブデザインを標準とする、モバイル端末表示を適正化するテンプレートシステムへの対応が行われており、このバージョンから管理画面のレスポンシブ対応も行われたことで、タブレット等のモバイル端末での、ショップの売上管理が楽になっています。

Zen Cart® v1.5.6 is designed for PHP 5.6 to 7.3, with MySQL 5.1 to 5.7 (or MariaDB 10.0-10.2) and Apache 2.2/2.4

  • PHP 7.3推奨, PHP 5.5 以降でも動作します
    (注意: PHP バージョン 5.6 よりも古いものは既に PHP サポートが終了しています... セキュリティの上でもパフォーマンスの上でも、十分な能力を得るには、最低でも PHP 7.1 を利用してください。
  • MySQL 5.1 - 5.7
  • Apache 2.2 - 2.4
  • Apache の AllowOverride 設定は、'All' もしくは、少なくとも 'Limit' と 'Indexes' の2つのパラメータは必要です。可能であれば、'Options' パラメータも追加してください。
  • PHP 設定では OpenSSL で CURL が利用できるようにしてください。
  • サーバーの CURL と OpenSSL については、最新の TLS が利用できるように設定してください。

Nginx がサポートされました。( IIS はサポートされません)

Zen cart v1.5.6a(日本語版)は、1.3.8a、1.3.9hの日本語版を独自公開した ビッグマウスが、今回も同様にお客様のニーズに応える形で、独自の日本語化と共に、日本の商習慣にあわせた各種のローカライズを追加したものです。

日本国内での販売にあわせた、振り仮名の追加やヤマト運輸、佐川急便の料金表に対応した配送モジュールを標準で装備するなど、これまでのノウハウを詰め込みました。

 

新しい Zen Cart v1.5.6a(日本語版)をダウンロード

  Zen Cart v1.5.6a(日本語版)デモサイト

なぜ、PHP7対応した新しいZencartを推奨する?

PHPが2018年の年末で、PHP5.6のサポートを終了させるという事がもっとも大きな要因です。
実際、多くのレンタルサーバー会社が提供するサービスにおいて、PHPのバージョンで7系が選択可能になっていますし、推奨されています。

弊社のお客様を含めた、多くの Zencart ユーザー様は、大変長く Zencart を使ってサイト運営を行っておられます。当然サーバー環境はもちろん、サーバープログラムのバージョンも新しくなり、古い環境のままでの利用は損なだけではなく、現在の安全基準に照らすと、不十分な状況になっています。一般的に、PHP7にすると、PHP5と比較して約2倍のスピードが出るといわれていますし、近年増加するカード詐欺や個人情報流出のリスクに対して、PCIセキュリティ基準はかなり厳しくなっています。(10年前の車の燃費や安全性能を現在の車と比べると格段の進歩がありますが、コンピューター業界の進歩のスピードはそれをはるかに上回る勢いで進んでいます)

ただし、新しくすることで発生する問題もあります。それだけの革新的な進歩を行おうとすれば、旧バージョンとの互換性が失われてしまう点です。(ある程度古い環境への対応を切り捨てざるを得ない)

弊社(ビックマウス)においては、最新の環境でのサイト運営を希望するクライアント様に十分なサービスを提供する方法として、PHP7に対応した新しいZencart v1.5.6 をベースとしてサービスを提供することにいたしました。

この決定により、これまでの v1.3.8a をベースにしている Zencart サイトに対しては、通常の方法でのバージョンアップは出来なくなりますが、なにとぞご理解ください。